const regex = /^[^\s@]+@[^\s@]+\.[^\s@]+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s@]+@[^\\s@]+\\.[^\\s@]+$', 'mg')
const str = `prettyandsimple@example.com
ryan+bar@gmail.com
verycommon@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
#!\$%&'*+-/=?^_\`{}|~@example.org
"()[]:,;@\\\\\\"!#\$%&'*+-/=?^_\`{}| ~.a"@example.org
" "@example.org
üñîçøðé@example.com
üñîçøðé@üñîçøðé.com
Pelé@example.com
δοκιμή@παράδειγμα.δοκιμή
我買@屋企.香港
甲斐@黒川.日本
чебурашка@ящик-с-апельсинами.рф`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}