$re = '/^[^\s@]+@[^\s@]+\.[^\s@]+$/m';
$str = 'prettyandsimple@example.com
ryan+bar@gmail.com
verycommon@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
#!$%&\'*+-/=?^_`{}|~@example.org
"()[]:,;@\\\\\\"!#$%&\'*+-/=?^_`{}| ~.a"@example.org
" "@example.org
üñîçøðé@example.com
üñîçøðé@üñîçøðé.com
Pelé@example.com
δοκιμή@παράδειγμα.δοκιμή
我買@屋企.香港
甲斐@黒川.日本
чебурашка@ящик-с-апельсинами.рф';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);