use strict;
my $str = 'prettyandsimple@example.com
ryan+bar@gmail.com
verycommon@example.com
very.common@example.com
disposable.style.email.with+symbol@example.com
other.email-with-dash@example.com
#!$%&\'*+-/=?^_`{}|~@example.org
"()[]:,;@\\\\\\"!#$%&\'*+-/=?^_`{}| ~.a"@example.org
" "@example.org
üñîçøðé@example.com
üñîçøðé@üñîçøðé.com
Pelé@example.com
δοκιμή@παράδειγμα.δοκιμή
我買@屋企.香港
甲斐@黒川.日本
чебурашка@ящик-с-апельсинами.рф';
my $regex = qr/^[^\s@]+@[^\s@]+\.[^\s@]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}