#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\d+|#}{,:\"\s\-]"
Local $sString = "{"0371-85962599/13203880520":0}" & @CRLF & _
"0536,18764723450" & @CRLF & _
"九华山景区电话:05662823169" & @CRLF & _
"0563-5580737|无添加" & @CRLF & _
"无" & @CRLF & _
"暂无" & @CRLF & _
"18831830882,地" & @CRLF & _
"13350447774/18990409600" & @CRLF & _
"{"0371-85962599":0}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")