// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[^\d+|#}{,:\"\s\-]"#).unwrap();
let string = "{\"0371-85962599/13203880520\":0}
0536,18764723450
九华山景区电话:05662823169
0563-5580737|无添加
无
暂无
18831830882,地
13350447774/18990409600
{\"0371-85962599\":0}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}