using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\d+|#}{,:\""\s\-]";
string input = @"{""0371-85962599/13203880520"":0}
0536,18764723450
九华山景区电话:05662823169
0563-5580737|无添加
无
暂无
18831830882,地
13350447774/18990409600
{""0371-85962599"":0}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}