$re = '/[^\d+|#}{,:\"\s\-]/m';
$str = '{"0371-85962599/13203880520":0}
0536,18764723450
九华山景区电话:05662823169
0563-5580737|无添加
无
暂无
18831830882,地
13350447774/18990409600
{"0371-85962599":0}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);