# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^\d+|#}{,:\"\s\-]"
test_str = ("{\"0371-85962599/13203880520\":0}\n"
"0536,18764723450\n"
"九华山景区电话:05662823169\n"
"0563-5580737|无添加\n"
"无\n"
"暂无\n"
"18831830882,地\n"
"13350447774/18990409600\n"
"{\"0371-85962599\":0}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.