package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\d+|#}{,:\"\s\-]`)
var str = `{"0371-85962599/13203880520":0}
0536,18764723450
九华山景区电话:05662823169
0563-5580737|无添加
无
暂无
18831830882,地
13350447774/18990409600
{"0371-85962599":0}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}