# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-zA-Z]{4}\s+[a-zA-Z]\d{3}(*SKIP)(*F)|\w+\W*//g;t' <<< "ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501"