const regex = /[a-zA-Z]{4}\s+[a-zA-Z]\d{3}(*SKIP)(*F)|\w+\W*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z]{4}\\s+[a-zA-Z]\\d{3}(*SKIP)(*F)|\\w+\\W*', 'g')
const str = `ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);