import re
regex = re.compile(r"[a-zA-Z]{4}\s+[a-zA-Z]\d{3}(*SKIP)(*F)|\w+\W*")
test_str = "ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)