re = /[a-zA-Z]{4}\s+[a-zA-Z]\d{3}(*SKIP)(*F)|\w+\W*/
str = 'ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result