#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[a-zA-Z]{4}\s+[a-zA-Z]\d{3}(*SKIP)(*F)|\w+\W*"
Local $sString = "ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)