import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]{4}\\s+[a-zA-Z]\\d{3}(*SKIP)(*F)|\\w+\\W*";
final String string = "ABEH A501; BIOL L340; BIOL Z620; Q799; ABEH A501";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}