using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\[)[a-zA-Z\W\s\n\d]+(?=\]).";
string input = @"{
“documents”: [
{
“workerName”: “some name”,
“fuelCardId”: ""443345 "",
“fuelLimit”: 120,
“documentID”: “75fb1ba5-1aef”
},
{
“workerName”: “some name”,
“fuelCardId”: ""4534564 "",
“fuelLimit”: 360,
“documentID”: “629e0056-7235”
},
{
“workerName”: “some name”,
“fuelCardId”: ""4564564 "",
“fuelLimit”: 899.9,
“documentID”: “3444bda1-d893”
}
]
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}