import Foundation
let pattern = #"(?=\[)[a-zA-Z\W\s\n\d]+(?=\])."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{
“documents”: [
{
“workerName”: “some name”,
“fuelCardId”: "443345 ",
“fuelLimit”: 120,
“documentID”: “75fb1ba5-1aef”
},
{
“workerName”: “some name”,
“fuelCardId”: "4534564 ",
“fuelLimit”: 360,
“documentID”: “629e0056-7235”
},
{
“workerName”: “some name”,
“fuelCardId”: "4564564 ",
“fuelLimit”: 899.9,
“documentID”: “3444bda1-d893”
}
]
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)