import re
regex = re.compile(r"(?=\[)[a-zA-Z\W\s\n\d]+(?=\]).", flags=re.MULTILINE)
test_str = ("{\n"
"“documents”: [\n"
"{\n"
"“workerName”: “some name”,\n"
"“fuelCardId”: \"443345 \",\n"
"“fuelLimit”: 120,\n"
"“documentID”: “75fb1ba5-1aef”\n"
"},\n"
"{\n"
"“workerName”: “some name”,\n"
"“fuelCardId”: \"4534564 \",\n"
"“fuelLimit”: 360,\n"
"“documentID”: “629e0056-7235”\n"
"},\n"
"{\n"
"“workerName”: “some name”,\n"
"“fuelCardId”: \"4564564 \",\n"
"“fuelLimit”: 899.9,\n"
"“documentID”: “3444bda1-d893”\n"
"}\n"
"]\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")