use strict;
my $str = '{
“documents”: [
{
“workerName”: “some name”,
“fuelCardId”: "443345 ",
“fuelLimit”: 120,
“documentID”: “75fb1ba5-1aef”
},
{
“workerName”: “some name”,
“fuelCardId”: "4534564 ",
“fuelLimit”: 360,
“documentID”: “629e0056-7235”
},
{
“workerName”: “some name”,
“fuelCardId”: "4564564 ",
“fuelLimit”: 899.9,
“documentID”: “3444bda1-d893”
}
]
}';
my $regex = qr/(?=\[)[a-zA-Z\W\s\n\d]+(?=\])./mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}