$re = '/(?=\[)[a-zA-Z\W\s\n\d]+(?=\])./m';
$str = '{
“documents”: [
{
“workerName”: “some name”,
“fuelCardId”: "443345 ",
“fuelLimit”: 120,
“documentID”: “75fb1ba5-1aef”
},
{
“workerName”: “some name”,
“fuelCardId”: "4534564 ",
“fuelLimit”: 360,
“documentID”: “629e0056-7235”
},
{
“workerName”: “some name”,
“fuelCardId”: "4564564 ",
“fuelLimit”: 899.9,
“documentID”: “3444bda1-d893”
}
]
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);