#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*([a-zA-Zа-яёЁ]){2,}.*"
Local $sString = "723374374er347" & @CRLF & _
"8374r8787rr878" & @CRLF & _
"74673не34677" & @CRLF & _
"37467364734r34" & @CRLF & _
"34737r8878r87r"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")