$re = '/.*([a-zA-Zа-яёЁ]){2,}.*/';
$str = '723374374er347
8374r8787rr878
74673не34677
37467364734r34
34737r8878r87r';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);