import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*([a-zA-Zа-яёЁ]){2,}.*";
final String string = "723374374er347\n"
+ "8374r8787rr878\n"
+ "74673не34677\n"
+ "37467364734r34\n"
+ "34737r8878r87r";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}