const regex = /.*([a-zA-Zа-яёЁ]){2,}.*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*([a-zA-Zа-яёЁ]){2,}.*', 'g')
const str = `723374374er347
8374r8787rr878
74673не34677
37467364734r34
34737r8878r87r`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}