package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*, )|(\..*)`)
var str = `Stengel, Mrs. Charles Emil Henry (Annie May Morris)
Barry, Miss. Julia
Leader, Dr. Alice (Farnham)
Butt, Major. Archibald Willingham
Goodwin, Master. Harold Victor
Stankovic, Mr. Ivan`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}