import re
regex = re.compile(r"(.*, )|(\..*)")
test_str = ("Stengel, Mrs. Charles Emil Henry (Annie May Morris)\n"
"Barry, Miss. Julia\n"
"Leader, Dr. Alice (Farnham)\n"
"Butt, Major. Archibald Willingham\n"
"Goodwin, Master. Harold Victor\n"
"Stankovic, Mr. Ivan")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")