$re = '/(.*, )|(\..*)/';
$str = 'Stengel, Mrs. Charles Emil Henry (Annie May Morris)
Barry, Miss. Julia
Leader, Dr. Alice (Farnham)
Butt, Major. Archibald Willingham
Goodwin, Master. Harold Victor
Stankovic, Mr. Ivan';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);