using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+\s*)\|([0-9a-f]+)\|\s*([A-Z])\s*\|\s*(\w+)\s*\|([0-9a-f]+)(?:\|(\s*[\w ]+\s*))?(?:\|(\s*[\w.: ]+\s*))?";
string input = @"__func_name |00010d88| T | FUNC|00000010| |.text
__func_name2|0007bb7c| T | FUNC|00000034| |.text sourcefile.c:49
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}