const regex = /^(\w+\s*)\|([0-9a-f]+)\|\s*([A-Z])\s*\|\s*(\w+)\s*\|([0-9a-f]+)(?:\|(\s*[\w ]+\s*))?(?:\|(\s*[\w.: ]+\s*))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+\\s*)\\|([0-9a-f]+)\\|\\s*([A-Z])\\s*\\|\\s*(\\w+)\\s*\\|([0-9a-f]+)(?:\\|(\\s*[\\w ]+\\s*))?(?:\\|(\\s*[\\w.: ]+\\s*))?', 'gm')
const str = `__func_name |00010d88| T | FUNC|00000010| |.text
__func_name2|0007bb7c| T | FUNC|00000034| |.text sourcefile.c:49
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}