import re
regex = re.compile(r"^(\w+\s*)\|([0-9a-f]+)\|\s*([A-Z])\s*\|\s*(\w+)\s*\|([0-9a-f]+)(?:\|(\s*[\w ]+\s*))?(?:\|(\s*[\w.: ]+\s*))?", flags=re.MULTILINE)
test_str = ("__func_name |00010d88| T | FUNC|00000010| |.text\n"
"__func_name2|0007bb7c| T | FUNC|00000034| |.text sourcefile.c:49\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")