package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+\s*)\|([0-9a-f]+)\|\s*([A-Z])\s*\|\s*(\w+)\s*\|([0-9a-f]+)(?:\|(\s*[\w ]+\s*))?(?:\|(\s*[\w.: ]+\s*))?`)
var str = `__func_name |00010d88| T | FUNC|00000010| |.text
__func_name2|0007bb7c| T | FUNC|00000034| |.text sourcefile.c:49
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}