use strict;
my $str = '__func_name |00010d88| T | FUNC|00000010| |.text
__func_name2|0007bb7c| T | FUNC|00000034| |.text sourcefile.c:49
';
my $regex = qr/^(\w+\s*)\|([0-9a-f]+)\|\s*([A-Z])\s*\|\s*(\w+)\s*\|([0-9a-f]+)(?:\|(\s*[\w ]+\s*))?(?:\|(\s*[\w.: ]+\s*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}