$re = '/^(\w+\s*)\|([0-9a-f]+)\|\s*([A-Z])\s*\|\s*(\w+)\s*\|([0-9a-f]+)(?:\|(\s*[\w ]+\s*))?(?:\|(\s*[\w.: ]+\s*))?/m';
$str = '__func_name |00010d88| T | FUNC|00000010| |.text
__func_name2|0007bb7c| T | FUNC|00000034| |.text sourcefile.c:49
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);