# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.).+ (\w+)/$1$2/gm;t' <<< "Tom Jones
Tom Smith Jones
Tom Mike Andrew Jones"