re = /^(.).+ (\w+)/m
str = 'Tom Jones
Tom Smith Jones
Tom Mike Andrew Jones'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result