const regex = /^(.).+ (\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.).+ (\\w+)', 'gm')
const str = `Tom Jones
Tom Smith Jones
Tom Mike Andrew Jones`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);