#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.).+ (\w+)"
Local $sString = "Tom Jones" & @CRLF & _
"Tom Smith Jones" & @CRLF & _
"Tom Mike Andrew Jones"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)