using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.).+ (\w+)";
string substitution = @"$1$2";
string input = @"Tom Jones
Tom Smith Jones
Tom Mike Andrew Jones";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}