$re = '/^(.).+ (\w+)/m';
$str = 'Tom Jones
Tom Smith Jones
Tom Mike Andrew Jones';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;