# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([a-z])\1+(?!\1|\b)|(?<=([a-z]))((?!\2)[a-z])\3+/$1$3/gm;t' <<< "aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa"