re = /\b([a-z])\1+(?!\1|\b)|(?<=([a-z]))((?!\2)[a-z])\3+/m
str = 'aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result