const regex = /\b([a-z])\1+(?!\1|\b)|(?<=([a-z]))((?!\2)[a-z])\3+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([a-z])\\1+(?!\\1|\\b)|(?<=([a-z]))((?!\\2)[a-z])\\3+', 'gm')
const str = `aaa baaab xxx
ahhj aaab cc iiik
bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);