import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([a-z])\\1+(?!\\1|\\b)|(?<=([a-z]))((?!\\2)[a-z])\\3+";
final String string = "aaa baaab xxx\n"
+ "ahhj aaab cc iiik\n"
+ "bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa";
final String subst = "$1$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}