import re
regex = re.compile(r"\b([a-z])\1+(?!\1|\b)|(?<=([a-z]))((?!\2)[a-z])\3+", flags=re.MULTILINE)
test_str = ("aaa baaab xxx\n"
"ahhj aaab cc iiik\n"
"bbb ahhj aaab cc iiik xxx fjjj baaaaaab yyyaaa")
subst = "$1$3"
result = regex.sub(subst, test_str)
if result:
print(result)