#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\w+$"
Local $sString = "Able County" & @CRLF & _
"Baker County" & @CRLF & _
"Charlie County" & @CRLF & _
"St. Louis County"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)