use strict;
my $str = 'Able County
Baker County
Charlie County
St. Louis County';
my $regex = qr/\s*\w+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";