re = /\s*\w+$/m
str = 'Able County
Baker County
Charlie County
St. Louis County'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result