const regex = new RegExp('\\s*\\w+$', 'gm')
const str = `Able County
Baker County
Charlie County
St. Louis County`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);