$re = '/\s*\w+$/m';
$str = 'Able County
Baker County
Charlie County
St. Louis County';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;