#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\|"([^|]*[^"|]\|)"
Local $sString = "||field2|"field3"|"field4|"field5"||"fie""ld6||field7|. the expected result would be ||field2|"field3"|field4|"field5"||fie""ld6||field7|"
Local $sSubst = "|$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)